Jump to content
Yet Another Minecraft Server (YAMS)
Sign in to follow this  
darrenstraight

10/04/2014 - YAMS and Minecraft 1.7.7

Recommended Posts

Minecraft 1.7.6 and 1.7.7 were released yesterday, this stopped some of you using the default Minecraft profile (always updates) from getting on.

 

May I remind you that as before with previous updates, we cant update the server to Minecraft 1.7.7 straight away for the simple fact that we have to wait until Bukkit / CraftBukkit and plugins have updated themselves to the latest version of Minecraft, without these plugins we could not guarantee the smooth running of YAMS.

 

Minecraft 1.7.7 is not a backwards compatible update, meaning if you update to 1.7.6 or 1.7.7 you will not be able to connect to a 1.7.5 server (what we are currently on). With that said now that we are using Spigot (a more efficient version of craftbukkit) we may be able to fix that with pixie dust or some good old magic (I'm currently backing up files before testing), I'll keep you all posted.

If you are using the default Minecraft profile which automatically updates its self and would like to come back onto YAMS, you will need to create a new profile within the Minecraft launcher using version "release 1.7.5".

 
As always I will keep you updated on the latest news of updating, if you have any concerns relating to YAMS and Minecraft 1.7.7 please feel free to ask in here and I'm sure someone will be able to answer you. Though some questions we wont know the answer too till it happens!

As explained in the past, please remember things may take a little while to be fully sorted once we do update.

Thank you,
Darren and the rest of the YAMS Staff.

 

P.S. On other news, 1.7.7 does not fix the issue of signs causing huge FPS drops, want this fixed? Up vote the issue!

Share this post


Link to post
Share on other sites

Magic has been used allowing you to connect to YAMS with Minecraft 1.7.7, though it will say "Can't connect to server." you should be able to ignore this and connect anyway. I have also updated some plugins in preparation for the whole player name change coming with Minecraft 1.8.

 

UPDATE: Ok seems 1.7.7 is no longer working, it was working fine this morning but now you get the message "Outdated server! pretending to be 1.7.7". Other servers who were also using this black magic are also having this issue so maybe Mojang stopped it. Foir now stick to a 1.7.5 profile if you want to connect please.

Share this post


Link to post
Share on other sites

There was some slight down time this morning as I tried moving us over to Minecraft 1.7.8, unfortunately however this did not go to plan as we have entries in our bans/whitelist that appear to be misspelt minecraft usernames so they are not being converted to UUID and added to the new whitelist/ban .json file format, I will need to manually check these before we can proceed with 1.7.8, for the time being however 1.7.8 clients seem to be able to connect just fine to us.

Share this post


Link to post
Share on other sites

I have now updated YAMS to Spigot for Minecraft 1.7.8.

 

I was having massive issues getting us over to Minecraft 1.7.8, CraftBukkit seemed to be very laggy after the whole file conversion while Spigot would not load as it requires you to now type in "yes" into the console to confirm you wish to upgrade the player files but our host doesn't allow us to type commands into the console until server has started.... but of course wouldn't start as needed to type yes.

 

Lucky one of the main developers md_5 fixed the issue for me in a new Spigot build version: https://github.com/SpigotMC/Spigot/commit/8bb505c271c52daf972d90a2475e5f62a4f58396#commitcomment-6018863

 

There are still some plugins that I need to update such as Chairs but I'll wait till there's no one on YAMS to do that. :)

 

I will update us to 1.7.9 as soon as we have a release for it.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...